Cloud Sensor Ingestion Delays

Incident Report for Arctic Wolf Public

Resolved

Upstream Vendors report their incidents have resolved
Arctic Wolf resources have verified recovery of ingestion for ESET and O365 Cloud Sensors.

Incident Resolved
Posted Jul 24, 2026 - 13:37 UTC

Update

We continue to monitor services affecting ingestion for ESET and O365 Cloud Sensors.

Next Update: 07/23/26 21:30 UTC
Posted Jul 23, 2026 - 20:26 UTC

Monitoring

We are aware of ongoing Vendor issues affecting ingestion for ESET and O365 Cloud Sensors.
Users may experience delays in ticketing for these event types.
Our teams are monitoring ESET and Microsoft services for recovery


Next Update: 07/23/26 20:00 UTC
Posted Jul 23, 2026 - 18:38 UTC
This incident affected: USA (Managed Detection and Response-Sensor Infrastructure), CA (Managed Detection and Response-Sensor Infrastructure), and EMEA (Managed Detection and Response-Sensor Infrastructure).